Square Terminal Kiosk Transaction Issue

Incident Report for Grayza Health

Identified

The team is currently working on a fix for this issue.
Another update will be provided once an ETA is known.
Posted Feb 26, 2026 - 09:17 AEST

Investigating

We’ve identified an issue affecting venues using Grayza kiosks with Square terminals.

Following our latest update to improve order visibility and speed, Square’s in-person order processing has shown unexpected conflicts with our updated flow. We are actively investigating.

In the meantime, we recommend temporarily disabling kiosks connected to Square terminals to avoid disruption.
QR and other ordering methods are not affected.
Posted Dec 12, 2025 - 10:56 AEST
This incident affects: Kiosk.